Fout bij het installeren van Alfresco Community 4.0.b - Niet-afgesloten Uqoted-reeks

Wanneer ik Alfresco 4.0.b probeer te installeren in de tekstmodus op Ubuntu 10.04, krijg ik de foutmelding:

./alfresco-community-4.0.b-installer-linux-x64.bin: 1: Syntax error: Unterminated quoted string

Is dit gerelateerd aan het installatieprogramma of Ubuntu? Sommigen helpen het te laten werken?

0
Mijn voorgevoel is dat je een corrupte download hebt - kun je de MD5-hash van je bestand controleren en controleren of het correct is?
toegevoegd de auteur Gagravarr, de bron
Heb je je probleem opgelost? Markeer een antwoord of voeg je eigen antwoord toe als je het zelf hebt opgelost.
toegevoegd de auteur Florian, de bron

2 antwoord

Ofwel corruptie, of je werkt aan een 32-bits besturingssysteem, gebruik de opdracht: uname -m om dit te weten, als het iets anders geeft dan: x86_64 dan gebruik je geen compatibele versie van UBUNTU, je moet ofwel een 64bit-versie installeren van UBUNTU of kies de hardcoded installatie van Alfresco, aangezien de 4e versie geen 32bit Alfresco-installatieprogramma heeft.

1
toegevoegd
uname -m geeft me "i686"
toegevoegd de auteur Kris, de bron
Lang geleden! Dan werk je aan 32 bit OS!
toegevoegd de auteur Yazid Erman, de bron

Had hetzelfde probleem maar loste het op door ervoor te zorgen dat .bin uitvoerbaar was door:

chmod 777 

Je moet het ook als root uitvoeren en './' vóór de bestandsnaam hebben:

$ ./alfresco-community-4.0.b-installer-linux-x64.bin

Ik heb sh gebruikt zoals ik gewend ben aan shell/bash-scripts. Ik denk dat dat is waarom het de "niet-genoteerde string" -fout bedacht.

Kan ook zijn dat ik chmod + a gebruikte in plaats van chmod 777 .

0
toegevoegd