Problemen met het implementeren van WebADF 10 naar Windows Server 2008 (64-bits)

Ik ben bezig een WebADF 931-app te migreren naar 10 en een aantal uitdagingen aan te gaan met depoloyment op 64-bits Server (Windows Server 2008 R2). De website werkt prima wanneer deze wordt geïmplementeerd op een 32-bits server maar gooit fouten in een 64-bits omgeving. Ik heb deze scripts uitgevoerd om ervoor te zorgen dat de server 32-bits is ingeschakeld (volgens de suggestie van ESRI). Ik mis nog steeds een aantal kritische instellingen. Ik ben op zoek naar wat feedback over wat ik nog meer zou kunnen proberen te bereiken.

  • cscript adsutil.vbs ingesteld w3svc/AppPools/Enable32bitAppOnWin64 1
  • % SYSTEMROOT% \ Microsoft.NET \ Framework \ v2.0.50727 \ aspnet_regiis.exe -i
  • zorg ervoor dat in de geavanceerde instelling "Ingeschakeld 32-bits toepassing" eigenschap is ingesteld op true

Bedankt vlaamse gaai

0
Is de applicatie gecompileerd naar x86 of Any CPU? Je zou het naar x86 moeten compileren.
toegevoegd de auteur Henrik, de bron
Bedankt voor het bericht, ik kan wat vooruitgang boeken. Ik zie dat de app de eerste keer goed wordt uitgevoerd, maar de tweede keer gooit deze deze foutmelding naar boven, wat voor ideeën dan ook [Page_Error Kan viewstate niet laden. De besturingsstructuur waarnaar de viewstate wordt geladen, moet overeenkomen met de besturingsstructuur die werd gebruikt om de viewstate op te slaan tijdens het vorige verzoek. Als u bijvoorbeeld besturingselementen dynamisch toevoegt, moeten de besturingselementen die tijdens een post-back zijn toegevoegd, overeenkomen met het type en de positie van de besturingselementen die tijdens het eerste verzoek zijn toegevoegd.] Bedankt, bedankt
toegevoegd de auteur janeylicious, de bron

Geen antwoorden

0