Lion en OpenGL-ondersteuning

Deze documentatie lezen
http://developer.apple.com/graphicsimaging/opengl/capabilities/ ik krijg die Lion-ondersteuning opent alleen GL2.1

Dit is een versie van 6 jaar oud, de huidige is de 4.2, Vertel me alsjeblieft dat ik het niet goed heb en dat we tenminste in de versie 3.2 zijn :) dit zou echt een heel groot probleem voor me zijn: P

0

2 antwoord

For more modern video cards (and software renderer) OSX does use 3.2 See Apple's doc on current video cards

1
toegevoegd

Ik denk dat je pech hebt, tenzij je het geluk hebt om één van de paar kaarten genoemd in het antwoord van Mark. De meeste nieuwe Macs, inclusief alle iMacs, ondersteunen slechts 2.1 volgens de apple.com-pagina die u verwezen . Deze blogpost door een expert in grafische programmering merkt ook op dat Apple geen stappen ondernomen om OpenCL 1.1 te ondersteunen (voor het programmeren van shaders).

0
toegevoegd
Weet je het zeker? ik heb een nieuwe iMac met AMD Radeon HD 6770M en op die pagina vond ik dat deze kaart OpenGL 3.2 ondersteunt (ik keek in "legacy" maar als je in "Core" gaat, vind je de juiste informatie).
toegevoegd de auteur Jimmy Hoffa, de bron
Nee, ik weet het niet zeker, sorry!
toegevoegd de auteur emory, de bron