= 0) ruby"> = 0) ruby"> = 0) ruby" />

vereisten voor het instellen van oude edelsteenversies zijn te streng

Ik ben een paar edelstenen tegengekomen, meestal niet vaak onderhouden. Ze zijn gemaakt voor een oudere versie van rails, maar werken meestal prima met een nieuwere versie.

Bundler could not find compatible versions for gem "actionpack":
  In snapshot (Gemfile.lock):
    actionpack (3.1.3)

  In Gemfile:
    astaire (>= 0) ruby depends on
      actionpack (~> 3.0.0.beta2) ruby

Wat ik eerder heb gedaan, is het juweel gesplitst en handmatig de versievereisten in de edelspecificatie gewijzigd. Is er een betere manier?

0
Heb je bundelupdate gedaan?
toegevoegd de auteur Dorian, de bron
Het probleem is een vereistenconflict - bundelupdate zou inderdaad erg in de war raken (kan het niet opnieuw uitvoeren om de fout nu te krijgen)
toegevoegd de auteur Peter Ehrlich, de bron

Geen antwoorden

0