Inloggen vereist in backend na instelling is_secure to false [Symfony]

Ik ga eerlijk gezegd gek met symfony. Ik had de sfDoctrineGuardUser-plug-in geïnstalleerd maar omdat deze een fout gaf die ik niet kon oplossen (Onbekende methode SfGuardUserTable :: retrieveByUsername) heb ik deze gedeïnstalleerd. In het bestand backend/config/security.yml heb ik op dit moment de optie voor is_secure ingesteld op false.

default:
  is_secure: false;

MAAR wanneer ik toegang tot backend_dev.php krijg, zegt het nog steeds:

Aanmelden vereist Deze pagina is niet openbaar.

Ik heb alle verwijzingen naar sfGuardPlugin verwijderd, geen andere is_secure eigenschap ingesteld in innerlijke modules en ik heb de cache ongeveer 10000000 keer opgeschoond.

HELP ME ALSTUBLIEFT!

2
Controleer symfony's log om te zien wat en waar doorverwijzingen naar de beveiligde pagina.
toegevoegd de auteur Maerlyn, de bron
Heb je je cache gewist?
toegevoegd de auteur William Durand, de bron

2 antwoord

Je moet de puntkomma verwijderen. De juiste instelling is:

default:
  is_secure: false

Wis tot slot uw cache voor de productieomgeving.

2
toegevoegd
Graag gedaan!
toegevoegd de auteur macgyver, de bron
Dank je! Dat was het!
toegevoegd de auteur Vika, de bron

Als u de cache hebt gewist en nog steeds wordt gevraagd om u aan te melden, kunt u controleren of u de instelling is_secure hebt ingeschakeld op moduleniveau. Symfony biedt veilige toegang op appniveau en moduleniveau, dus als uw app-configuratie is ingesteld op is_secure: false , is uw moduleconfiguratie mogelijk nog steeds is_secure: true .

0
toegevoegd