jsTestDriver) QUnitAdapter.js supports the equals"> jsTestDriver) QUnitAdapter.js supports the equals"> jsTestDriver) QUnitAdapter.js supports the equals" />

Verkeerde versies bij gebruik van de QUnit met JSTestDriver-adapter (QUnitAdapter.js)

I'm trying to run unit tests written in QUnit using jsTestDriver. I'm getting "ReferenceError: equal is not defined". Checking the source code shows that the adapter (Qunit->jsTestDriver) QUnitAdapter.js supports the equals method:

window.equals = function(a, b, msg) {...}

While Qunit does not support equals (renamed to equal last year).

Mis ik hier iets?

postscriptum Ik gebruik jsTestDriver die is geïntegreerd in WebStorm 4.

0

1 antwoord

Ik neem aan dat u de QUnitAdapter gebruikt van de JsTestDriver-website. Momenteel ondersteunt de adapter op die site slechts een kleine subset van wat QUnit kan, dus u moet de veel meer up-to-date en volwassen gebruikte QUnitAdapter gebruiken hier . Ik schreef een bericht dat laat zien hoe je QUnit, Requirejs en codedekking integreert met JSTD: js-testrijder + qunit + dekking + requirejs . Hoop dat het helpt.

2
toegevoegd